•  
    Results 1 to 3 of 3

    Thread: Just bought a 2011 Aveo, some questions.

    1. #1
      What's wrong with my car?
      Join Date
      Mar 2023
      Location
      Ohio
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Just bought a 2011 Aveo, some questions.

      I just bought this thing basically sight unseen as a gas saver. Seems to run and shift well, only has 96k miles. Doesnít seem like it was owned by a very mindful person, so it was not particularly well maintained. The exhausted is rusted in half right behind the rear driver side tire (pretty rusted along entire exhaust actually). Hood latch release cable was completely gone. Had to sawzall the latch and replace it to get the hood open. Oil was clean but looked like there was a leak at the heat shield in the front. Thereís a little plastic electric plug behind the grill but in front of the radiator toward the driver side that isnít plugged into anything, no idea what it is. And suspension seems a little noisy all the way around. I know these 2011s arenít anything special so if anyone has any advice Iím all ears. Any answers on my mystery plug or other issues would be appreciated also. Thanks guys!



    2. #2
      What's wrong with my car?
      Join Date
      Mar 2023
      Location
      Canada
      Posts
      6
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      It's obviously been used in the north with salted roads. The exhaust only rusts out on salted roads, and the plug means it had a block heater. The Aveo suspension has always been noisy. It's an econo-box!

    3. #3
      What's wrong with my car?
      Join Date
      Oct 2022
      Location
      USA
      Posts
      20
      Thanks
      0
      Thanked 2 Times in 2 Posts
      Probably replace all coolant heater hoses, timing belt and idler tensioner, oil leak if under the exhaust heat shield it's probably the oil cooler and housing o rings don't buy the Chinese ones as they will leak mine lasted 2 weeks, probably valve cover gasket also serpentine belt and thermostat unless you have some idea when that was all replaced.


      Last edited by sjcleckley1; 05-02-2023 at 09:13 PM.

    Similar Threads

    1. Just bought an Aveo LS 2011
      By fusionalb in forum Introductions
      Replies: 1
      Last Post: 02-07-2018, 07:21 PM
    2. 2007 Aveo - bought used - maintenance questions
      By jaydoc in forum Troubleshooting and Maintenance
      Replies: 8
      Last Post: 06-27-2014, 09:48 PM
    3. Just bought 2004 Aveo Hatchback. Two electrical type questions.
      By strra in forum Troubleshooting and Maintenance
      Replies: 3
      Last Post: 06-14-2014, 04:31 AM
    4. New to the forum. Just Bought My '09 Aveo , Looking for some help.
      By newfiebullet in forum Troubleshooting and Maintenance
      Replies: 6
      Last Post: 08-08-2013, 02:51 AM
    5. I just bought an aveo- interested in beefing it up a little
      By yellowaveo1988 in forum Engine & Drivetrain
      Replies: 32
      Last Post: 03-15-2007, 04:28 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •