•  
    Results 1 to 6 of 6

    Thread: 2008 Aveo 5 stalls on decel, will not idle. No Codes

    1. #1
      What's wrong with my car? rotorhead's Avatar
      Join Date
      Jan 2019
      Location
      Beaverton Oregon
      Posts
      2
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Post 2008 Aveo 5 stalls on decel, will not idle. No Codes

      This morning I started my car with no problem as usual. Drove a couple of miles and the engine died turning a corner. It restarted when I let the clutch out. Then it died at every stop or deceleration but started right up. It drove smoothly with plenty of power as long as I applied throttle. It died as soon as I let off the gas. There are no codes present or pending. This is out of the blue. Last night it performed fine as always. Help please!



    2. #2
      What's wrong with my car? AveoChick's Avatar
      Join Date
      Dec 2016
      Location
      North Carolina
      Posts
      16
      Garage empty: add car
      Thanks
      0
      Thanked 1 Time in 1 Post
      Quote Originally Posted by rotorhead View Post
      This morning I started my car with no problem as usual. Drove a couple of miles and the engine died turning a corner. It restarted when I let the clutch out. Then it died at every stop or deceleration but started right up. It drove smoothly with plenty of power as long as I applied throttle. It died as soon as I let off the gas. There are no codes present or pending. This is out of the blue. Last night it performed fine as always. Help please!
      Possibilities I think of. Crankshaft/Camshaft position sensors. Idle air control valve, in the 2010 Aveo 5 this is incorporated into the throttle body unit itself.

    3. #3
      What's wrong with my car?
      Join Date
      Jan 2020
      Location
      illinois
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Did you ever find a solution to your problem? My 07 just started doing the same thing as you described.

    4. #4
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      552
      Thanks
      1
      Thanked 53 Times in 50 Posts
      I’d start simple and look for a vacuum leak.

    5. #5
      What's wrong with my car?
      Join Date
      Jul 2022
      Location
      Kearney Nebraska
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      It could be as simpl3 as inspecting the throttle body. It might be gummed up and sticky. It is not a hard job, but just keep in mind, if it is an electronic system make sure you are very easy on the plate and don't move it. If you move the plate you will have to take to dealership to get recalibration done.

    6. #6
      What do you mean there's no turbo? northguest47's Avatar
      Join Date
      Feb 2011
      Location
      Rural South, ON
      Posts
      438
      Thanks
      16
      Thanked 32 Times in 29 Posts
      agree with Eg.h2o there is a cracked hose somewhere, now its a cheap fix, but finding the crack...

      same thing happened to me years ago the car goes into limp mode, but with the deceleration

      its a cracked hose / hose leak thats my amateur bet

      i'll find the link..





    Similar Threads

    1. Wobbly transmission; lurching on accel or decel; hard shifting; too much clutch play
      By NeuteredZebra in forum Troubleshooting and Maintenance
      Replies: 1
      Last Post: 07-28-2020, 03:33 AM
    2. 2005 Aveo Will not idle stalls right after start
      By Joe05aveo in forum Engine & Drivetrain
      Replies: 2
      Last Post: 08-05-2017, 05:23 PM
    3. Replies: 2
      Last Post: 06-12-2015, 09:10 PM
    4. car starts, stalls, starts, stalls, runs and low rpms, is fine when warm.
      By barbor98 in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 08-28-2014, 11:09 PM
    5. 2008 aveo,lost power for awile,next day will not start,or trying but stalls
      By sidlas in forum Troubleshooting and Maintenance
      Replies: 9
      Last Post: 09-17-2012, 02:46 AM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •