•  
    Results 1 to 3 of 3

    Thread: Engine vibrate

    1. #1
      What's wrong with my car?
      Join Date
      Aug 2019
      Location
      New York
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Engine vibrate

      I have 2007 Chevrolet aveo, engine vibrate and pulling sometimes go off when I accelerate to it. I have changed the fuel pump, spark plugs but still same fault. does anybody face this type of problem in his aveo? Facing this problem from almost 1 week looking for the solution thanks.



    2. #2
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      65
      Thanks
      0
      Thanked 5 Times in 5 Posts
      Bad drivetrain mount?

    3. #3
      Should I keep it?
      Join Date
      Mar 2015
      Location
      SC
      Posts
      75
      Garage empty: add car
      Thanks
      0
      Thanked 4 Times in 4 Posts
      Could be a loose plug wire or bad engine mount.



    Similar Threads

    1. Replies: 3
      Last Post: 03-10-2014, 09:43 PM
    2. Replies: 58
      Last Post: 02-03-2014, 03:41 PM
    3. Replies: 0
      Last Post: 10-15-2012, 02:33 AM
    4. turbo charging, engine swap or engine build up
      By BS1313 in forum Engine & Drivetrain
      Replies: 8
      Last Post: 12-10-2011, 04:24 PM
    5. Replies: 14
      Last Post: 10-08-2010, 02:50 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •