•  
    Results 1 to 5 of 5

    Thread: 2008 Aveo5 Rear Washer

    1. #1
      What's wrong with my car?
      Join Date
      Mar 2021
      Location
      New York
      Posts
      3
      Thanks
      0
      Thanked 0 Times in 0 Posts

      2008 Aveo5 Rear Washer

      I know there is a thread or two about issues with the rear washer not working, but did not see my exact issue so posting a new thread.

      The front washer works fine, but the rear window washer does not. There is fluid going to the hoses in the rear hatch, and when I engage the rear washer while the hatch is open, washer comes out. However, nothing when the hatch is closed. Since fluid comes out when the hatch is open, I'm thinking maybe gravity is helping to push the fluid through the hose, which leads me to believe the pump for the rear washer is basically dead?

      If anyone can confirm my diagnosis, that would be greatly appreciated. Thank you!



    2. #2
      Should I keep it?
      Join Date
      Jul 2020
      Location
      CT
      Posts
      54
      Thanks
      6
      Thanked 1 Time in 1 Post
      i doubt there are two washers seems like a clog 8.00 buy a splice kit new hoses maybe cut it and air compressor it???

    3. #3
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      159
      Thanks
      0
      Thanked 13 Times in 13 Posts
      Quote Originally Posted by dfphoto View Post
      i doubt there are two washers seems like a clog 8.00 buy a splice kit new hoses maybe cut it and air compressor it???
      yes there are two washer pumps installed on the washer jug. Switch the hoses and use the front squirts. If it works, the rear pump is dead.

    4. #4
      What's wrong with my car?
      Join Date
      Mar 2021
      Location
      New York
      Posts
      3
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Quote Originally Posted by Eg.h2o View Post
      yes there are two washer pumps installed on the washer jug. Switch the hoses and use the front squirts. If it works, the rear pump is dead.
      OK, that's a good idea, I'll try that out. I read on another post that one has to remove the front fender lining to get to it, is that true?

      Thank you!

    5. #5
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      159
      Thanks
      0
      Thanked 13 Times in 13 Posts
      You’ll have to pop part of it out of the way, yes.





    Similar Threads

    1. How Do I Replace The REAR Windshield Washer Pump.....On my 2006 Aveo HB?
      By FlaAveo5 in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 09-01-2018, 04:30 PM
    2. Windshield washer fluid pump
      By jriggs87 in forum Troubleshooting and Maintenance
      Replies: 11
      Last Post: 11-16-2011, 02:23 AM
    3. Windshield Washer Hood Lights
      By EvySpeedy254 in forum How-To
      Replies: 1
      Last Post: 05-24-2010, 03:51 PM
    4. Window Washer nozzle's
      By Brainless in forum Exterior
      Replies: 5
      Last Post: 11-15-2007, 05:16 PM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •