•  
    Page 1 of 2 12 LastLast
    Results 1 to 10 of 15

    Thread: 2004 Aveo won't start

    1. #1
      What's wrong with my car?
      Join Date
      Mar 2011
      Location
      NY
      Posts
      16
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Unhappy 2004 Aveo won't start

      Replaced starter as it would not turn the engine over.Does that fine now but....I've got no fuel pump prime and no spark at the plugs. Is there a theft deterrent feature that shuts off both the fuel pump and the ignition.Battery was disconnected several times,would that make the keys become mismatched to the ecm,pcm or bcm??.For the past month had multiple times when the starter solenoid would only "buzz" and not engage.Then it would finally catch and start the car. Now I can't even hear the pump start with key on even though I checked the fuses for twelve volts and they were fine.What am I overlooking??



    2. #2
      Lifetime owner
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      8,013
      Garage empty: add car
      Thanks
      2
      Thanked 166 Times in 139 Posts
      You know there is no spark or fuel, what does the car do?

      The car does have some sort of immobilizer, but i have yet come across anything that states specifically how it stops the car.

      If you turn the key to the on position, do you see the CEL?


    3. #3
      What's wrong with my car?
      Join Date
      Mar 2011
      Location
      NY
      Posts
      16
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Quote Originally Posted by petrified.rabbit View Post
      You know there is no spark or fuel, what does the car do? Just spins over and does not even try to fire

      The car does have some sort of immobilizer, but i have yet come across anything that states specifically how it stops the car.

      If you turn the key to the on position, do you see the CEL?
      No cel visible Fuel gauge does not seem to read either

    4. #4
      Lifetime owner
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      8,013
      Garage empty: add car
      Thanks
      2
      Thanked 166 Times in 139 Posts
      check for voltage to the ecu? ecu fuses/relay?


    5. #5
      What's wrong with my car?
      Join Date
      Mar 2011
      Location
      NY
      Posts
      16
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Is there a "master" relay that powers the fuel pump and ignition??

    6. #6
      What's wrong with my car?
      Join Date
      Mar 2011
      Location
      NY
      Posts
      16
      Thanks
      0
      Thanked 0 Times in 0 Posts
      I've checked the 2 ecm fuses and they are not blown and I see 12 volts on one side of the fuse socket with the fuse removed.Where is the ecu relay located??

    7. #7
      What's wrong with my car?
      Join Date
      Mar 2011
      Location
      NY
      Posts
      16
      Thanks
      0
      Thanked 0 Times in 0 Posts
      I can also "feel" the fuel pump relay click on........ Any chance this could be the crank sensor?

    8. #8
      What's wrong with my car?
      Join Date
      Mar 2011
      Location
      NY
      Posts
      16
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Where is the ecm located?

    9. #9
      What's wrong with my car?
      Join Date
      Mar 2011
      Location
      NY
      Posts
      16
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Put a used ECM in and Voila Fuel pump primes and engine runs. !!! Do I now have to "flash" the ECM? How is that done? What does that do to the ECM................Is there any reason not to drive it now?

    10. #10
      Lifetime owner
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      8,013
      Garage empty: add car
      Thanks
      2
      Thanked 166 Times in 139 Posts
      if it ran, and the ecm matched options, you should be ok. Most likely, the damage would be done the first time you started it.






    Page 1 of 2 12 LastLast

    Similar Threads

    1. 2004 Chevy Aveo will not start
      By hillbillyhook in forum Troubleshooting and Maintenance
      Replies: 9
      Last Post: 09-15-2012, 04:52 PM
    2. 06 Aveo LS - Cranks no start, smell of gas
      By DMicro in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 08-03-2011, 02:19 AM
    3. 2004 Holden Barina body kit on 2004 Aveo
      By turbobuick88 in forum Exterior
      Replies: 2
      Last Post: 11-17-2010, 06:18 PM
    4. Pictures* The Start of the Aveo :P
      By Siege in forum Introductions
      Replies: 6
      Last Post: 08-13-2010, 06:56 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •