•  
    Results 1 to 5 of 5

    Thread: I removed my throttle body to clean it and shouldn't have

    1. #1
      What's wrong with my car?
      Join Date
      Apr 2016
      Location
      Philly
      Posts
      6
      Thanks
      0
      Thanked 0 Times in 0 Posts

      I removed my throttle body to clean it and shouldn't have

      I removed my throttle body in my 2010 chevy aveo LT 1.6 4 cyl to clean the whole throttle body assembly. I might have damaged the throttle body because i try to open the electronic plastic cover and now it will not close tight with the metal tabs on it. I know now i done something wrong because after reinstalling the throttle body i got two codes p0122 and po223. The engine idles and shakes rough and i can hardly accel the pedal driving. I checked all my work and made sure connections were clean and tight but now the computer cannot understand the throttle body so i am getting these two throttle position sensor codes.

      Should I just replace the throttle body? I think i damaged it because with an electronic throttle body you cannot open the throttle plate and pry open the plastic cover. Someone from A GM Dealer told me i had a throttle position sensor but i do not because it's built in.

      If I do replace the throttle body, can you tell me what relearn i can do after it's replace. i would appreciate it because I was about to buy a new throttle body thinking i damage it. I looked all over google and there are relearns but i hope i don't need an expensive scan tool to relearn the throttle body. I do have a scanner to reset the codes. I try to reset codes but that didn't do anything. I hope someone can help me. I know i shouldn't have taken it apart. The vehicle was running fine before but i wanted to clean it and now i cannot even drive it.


      Last edited by 10GoodAveo; 10-23-2021 at 04:46 AM.

    2. #2
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      253
      Thanks
      0
      Thanked 21 Times in 20 Posts
      Second post down on this thread

      https://www.aveoforum.com/forum/f108...cedures-16863/

      try this before replacing the throttle body. It may work
      Last edited by Eg.h2o; 10-23-2021 at 05:13 AM.

    3. #3
      edk
      edk is offline
      What's wrong with my car?
      Join Date
      Jul 2013
      Location
      Warwick, RI
      Posts
      15
      Thanks
      0
      Thanked 0 Times in 0 Posts
      I have gotten the same codes on my ‘09’. It was a split in the rubber boot from the throttle body to the intake. I think you’ll find that those codes indicate a lean burn condition and is caused by air leaking into the system past the mass air flow sensor. Try checking for leaks before replacing the throttle body
      Last edited by edk; 11-10-2021 at 08:05 PM. Reason: Additional

    4. #4
      What's wrong with my car?
      Join Date
      Nov 2016
      Location
      Massachusetts
      Posts
      10
      Thanks
      1
      Thanked 3 Times in 2 Posts
      Definitely look for vacuum leaks first... I found the bottom of the intake tube split and leaking on mine. New tube fixed it with no need to relearn.

    5. #5
      Should I keep it?
      Join Date
      Jun 2017
      Location
      ks
      Posts
      53
      Thanks
      8
      Thanked 0 Times in 0 Posts
      my first guess wud be MAF sensor, mass air flow sensor, tells cpu to control fuel/air ratio mix , TPS throttle position sensor also to control fuel ratio for injector to keep up flow, to restrict or increase fuel, this is accomplished by means of tiny bare wire runs across opening of throttle body, it heats up as air travels across it cools , as throttle position increases or decreases , wire gets hotter or cooler , either increase/decrease air flow needed to cool wire to maintain ambient air temperature, wire is broke or sensor got wet , defective, damaged, not getting correct voltage or bad ground wire connection





    Similar Threads

    1. Help! All i did was clean the throttle body!
      By Scanman in forum Troubleshooting and Maintenance
      Replies: 3
      Last Post: 05-19-2014, 02:25 PM
    2. looking for a throttle body and cat converter for 07 aveo
      By suffolkss409 in forum For Sale / Wanted
      Replies: 0
      Last Post: 07-29-2013, 01:37 AM
    3. How do I clean the throttle body?
      By Shinare in forum Engine & Drivetrain
      Replies: 2
      Last Post: 04-06-2012, 10:16 PM
    4. Should I or Shouldn't I.. get a Exhaust for my Chevrolet Aveo Ls?
      By UniqueAveox in forum General Discussion
      Replies: 1
      Last Post: 10-18-2011, 05:00 AM
    5. Check engine light after clean throttle
      By DOSALOGA in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 10-08-2011, 11:15 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •