•  
    Results 1 to 3 of 3

    Thread: Any advice/help

    1. #1
      What's wrong with my car?
      Join Date
      Aug 2007
      Location
      So. CT
      Posts
      12
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Any advice/help

      I have a 2004 Aveo LS sedan with 41,000 miles on it. It was purchased new. One of the first in CT I think. Ordered in Jan. of 2004 and did not arrive here until May! Has every factory option. Great little car with really no major problems.

      A few questions, I have never really had great gas mileage with this car? My 2010 Ford Escape 4 cyl. AWD gets better mileage! I have read here that others have talked about all different spark plugs for good mileage, but everyone seems to have a different opinion. Is there one that I should definitely try? I think the car is very peppy.

      A long time ago, the key in ignition and headlights on buzzer stopped working. ANY clue where would be a good place to start. I have been told several times that there must be a short somewhere but nobody seems to want to take the time to find it.

      Lastly, for now, I THINK the head gasket is leaking oil because it looks wet there. I have not seen any oil spots on the ground but I can smell it when I drive it.

      Thank you for any advice you can give me. 👍👍🤷🤷🤷



    2. #2
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      65
      Thanks
      0
      Thanked 5 Times in 5 Posts
      More than likely your valve cover gasket is leaking into your spark plug wells, and the outside perimeter of your engine, dripping down the head. If you pull the plug wires and plugs, I’m pretty sure you’ll see oil on them. Most people agree that regular copper plugs are the way to go with this engine. More expensive is not always better.
      i would pick up NGK or Bosh plugs (no platinum, just copper), or your plug of choice, and a new valve cover gasket. Most likely the oil smell will go away....
      Last edited by Eg.h2o; 09-06-2019 at 09:05 PM.

    3. #3
      What's wrong with my car?
      Join Date
      Aug 2007
      Location
      So. CT
      Posts
      12
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Thumbs up

      Quote Originally Posted by Eg.h2o View Post
      More than likely your valve cover gasket is leaking into your spark plug wells, and the outside perimeter of your engine, dripping down the head. If you pull the plug wires and plugs, I’m pretty sure you’ll see oil on them. Most people agree that regular copper plugs are the way to go with this engine. More expensive is not always better.
      i would pick up NGK or Bosh plugs (no platinum, just copper), or your plug of choice, and a new valve cover gasket. Most likely the oil smell will go away....
      Thank you for your help. I will have my garage check it out.



    Similar Threads

    1. Just purchased used 08 Aveo...any advice?
      By allbutsix in forum General Discussion
      Replies: 26
      Last Post: 02-10-2012, 10:31 PM
    2. Any advice on a broken timing belt that had under 12,000 miles on it?
      By ChevyAveoOwner11830 in forum General Discussion
      Replies: 2
      Last Post: 04-10-2011, 06:42 PM
    3. Chug a lug, lurch, burp & dead! Any advice?
      By cliffy in forum Troubleshooting and Maintenance
      Replies: 4
      Last Post: 02-01-2011, 06:25 PM
    4. Parking lights (not working - replaced bulb - any advice?)
      By brendan_m09 in forum Troubleshooting and Maintenance
      Replies: 6
      Last Post: 01-19-2011, 08:19 PM
    5. What do you think of this setup? Help/Advice
      By bdc87 in forum Audio, Video & Interior
      Replies: 2
      Last Post: 05-13-2010, 10:38 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •