•  
    Results 1 to 1 of 1

    Thread: My Aveo :: 2006 Chevrolet Aveo LS

    1. Ladyjew55ia is offline What's wrong with my car?
      Join Date
      Jun 2024
      Posts
      3
      General Information
      My Aveo
      2006
      Chevrolet
      Aveo LS
      Red
       
       
      •  
      Modifications

      P185/60R14

      •  

      Water is leaking from the backside of the engine just underneath the top of the engine....That's the only way I can explain it....Ummm..If you were to lay your hand on the top of the engine and then slide ur hand all the way to the back of it and just go down it's right there....I'm thinking it's missing a clamp or something on a hose because I know it's coming from the motor or anything... Hopefully it's not anyways!! What do you think?? Also I was driving and my battery light came on and then when I turned the car off it wouldn't start so once I charged the battery I got it going again but the same thing happened so I bought and replaced the alternator and surpentine belt and even bought a new battery everything was fine once replaced but then the other day I was driving it around and had been all day out the blue the battery light came back on and I turned it off and it wouldn't start back so I got a boost and was able to get it home but it is blowing my mind as to why this keeps happening...please help me with this?? Thank you!!

      •  
      Comments: 0 / Views: 112

    Similar Threads

    1. Chevy Aveo 2006 :: 2006 Chevrolet Aveo (Garage entry)
      By qc4000 in forum Members' Aveos / Garages
      Replies: 0
      Last Post: 02-15-2019, 05:12 AM
    2. My 2006 Icelandic Blue Aveo :: 2006 Chevrolet Aveo LS (Garage entry)
      By MetroMPG in forum Members' Aveos / Garages
      Replies: 0
      Last Post: 12-18-2014, 03:43 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •