• AveoForum decals - get one free, or buy
    Page 1 of 3 123 LastLast
    Results 1 to 10 of 21

    Thread: Car slows down on road by itself-gas pedal sensor?

    1. #1
      Junior Member
      Join Date
      Aug 2010
      Posts
      23
      Garage empty: add car

      Car slows down on road by itself-gas pedal sensor?

      Hi I have a 2006 Aveo ,standard. I hit the highway at 100km/ hour (60 in miles) then suddenly the car will slow down to 30 -40 and there is nothing I can do I hit the gas pedal and it won't go more than 30 or 20. I stop on the side of the road ,turn off my car wait 5 mins and start it up again. It will be fine for another 10-15 mins ride and it will do it again. It happened 5 times last night. I am being told it is the gas sensor.Has anyone had this problem. I would greatly appreciate the help pls.



    2. #2
      Senior Member ontarian_frog's Avatar
      Join Date
      Dec 2006
      Location
      Fredericton, NB
      Posts
      1,356
      Garage empty: add car
      Sounds like a dirty or bad throttle body. I'd try to clean it first. Unfortunately on this car, the tps is part of the throttle body, so if it's bad, you need to get the whole assembly.
      I leased Pontiac Wave from September 2006 to August 2011.

    3. #3
      Junior Member
      Join Date
      Aug 2010
      Posts
      23
      Garage empty: add car
      Thks for reply what is and where is the throttle body? TPS is a sensor?

    4. #4
      Junior Member
      Join Date
      Aug 2010
      Posts
      23
      Garage empty: add car
      anyone else have an idea on cleaning this ?

    5. #5
      Senior Member khan4rtist's Avatar
      Join Date
      Dec 2006
      Location
      Fontana, California
      Posts
      883
      Do you have a check engine light? Ive had a simlar problem in the past. But CEL codes would help narrow it down.

    6. #6
      Junior Member
      Join Date
      Aug 2010
      Posts
      23
      Garage empty: add car
      Hi yes I have a check ebgine light and with the code reader ,they , the garage get 3 codes.

    7. #7
      Administrator Daox's Avatar
      Join Date
      Jan 2007
      Location
      Wisconsin
      Posts
      1,794
      And the 3 codes are?

    8. #8
      Senior Member
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      7,171
      Garage empty: add car
      there are several things that could cause this, the codes are going to be the only way to narrow it down.
      Last edited by petrified.rabbit; 07-05-2012 at 06:46 PM.


    9. #9
      Junior Member
      Join Date
      Aug 2010
      Posts
      23
      Garage empty: add car
      Garage still has those codes, i'm going to another garage Monday ,they will read codes again, if I had the codes I would have given them here ,sorry. The first garage has not been helpful, pretty useless in fact.

    10. #10
      Senior Member Chevy Customer Svc's Avatar
      Join Date
      Jan 2012
      Location
      Detroit, Michigan
      Posts
      339
      Garage empty: add car
      Quote Originally Posted by Leotardtearer22 View Post
      Hi I have a 2006 Aveo ,standard. I hit the highway at 100km/ hour (60 in miles) then suddenly the car will slow down to 30 -40 and there is nothing I can do I hit the gas pedal and it won't go more than 30 or 20. I stop on the side of the road ,turn off my car wait 5 mins and start it up again. It will be fine for another 10-15 mins ride and it will do it again. It happened 5 times last night. I am being told it is the gas sensor.Has anyone had this problem. I would greatly appreciate the help pls.
      Your concern is certainly understood regarding your Aveo. If you would like, please send the VIN# and I can see if there are any known issues like this. A GM Certified Tech should also be well-equipped to resolve your concerns. I hope you find a quick solution for this issue.

      Matt (Assisting Vanessa)

      GM Customer Assistance



    Page 1 of 3 123 LastLast

    Similar Threads

    1. Brake pedal stiff at startup
      By Boardin_ut in forum Wheels, Tires, Brakes & Suspension
      Replies: 3
      Last Post: 08-02-2013, 09:10 PM
    2. Off Road Racing
      By culkell in forum Racing
      Replies: 10
      Last Post: 06-30-2012, 10:01 AM
    3. Aveo brake pedal travels to floor and weak brakes.
      By sledneck800 in forum Troubleshooting and Maintenance
      Replies: 4
      Last Post: 05-29-2012, 09:15 PM
    4. a "chug" sound while pressing the brake pedal
      By rommel in forum Wheels, Tires, Brakes & Suspension
      Replies: 5
      Last Post: 01-05-2012, 06:16 PM
    5. Road Rage!
      By thehunterooo in forum Open Forum
      Replies: 30
      Last Post: 06-23-2010, 01:48 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •