•  
    Results 1 to 6 of 6

    Thread: Help! Timing belt broke, fixed head, now 4 o-rings that I can't find where they go

    1. #1
      What's wrong with my car?
      Join Date
      Jul 2014
      Location
      Maine
      Posts
      6
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Help! Timing belt broke, fixed head, now 4 o-rings that I can't find where they go

      I'm working on an '06 Aveo that a friend of mine picked up with a broken timing belt. So I pulled the head off and sent it to the machine shop to have the valve guides replaced (all 16 were broken). The problem is, the machinist (his buddy) went on vacation for 3 weeks. So here it is, almost a month later, and I'm trying to remember how to put it back together. The biggest issue is, I have 4 o-rings, about 1/2" OD, that I can't for the life of me remember where they came from or find a home for. Can anyone help?

      EDIT: The injector rail was never removed from the intake manifold, so they're not from injectors.

      Another edit: I actually have 6 of the old o-rings, and the head gasket set came with 14 new ones. I don't think they came out of the top of the valve cover, because there are o-rings there already. I cannot find them anywhere in the GM Service manual, either.


      Last edited by JustCoz; 07-25-2014 at 10:33 PM.

    2. #2
      Lifetime owner
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      8,010
      Garage empty: add car
      Thanks
      2
      Thanked 162 Times in 135 Posts
      When you said 4 i thought on the spark plug galleys under the valve cover. but now that there is 14.

      did your gasket set come with a list? anymore they don't seem to. I would guess and say they are for the intake stuff that you probably didn't remove.


    3. #3
      What's wrong with my car?
      Join Date
      Jul 2014
      Location
      Maine
      Posts
      6
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      I suspect the 6 that I found were removed from the stuff I (or the previous owner) did take apart, and there are 8 more new ones for other stuff I didn't remove, like EGR and water passages and such from the intake manifold. The set also has 8 more smaller and fatter o-rings, I suspect these are for the injectors. The spark plug galleys don't have o-rings, their seals are part of the valve cover gasket. These are also too small for that, they're only about 1/2"/13mm OD and probably 10 or 11mm ID, most spark plugs are an M14 thread and take either a 5/8" or 13/16" socket.
      Last edited by JustCoz; 07-26-2014 at 01:54 AM.

    4. #4
      Lifetime owner
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      8,010
      Garage empty: add car
      Thanks
      2
      Thanked 162 Times in 135 Posts
      I'm looking at an exploded view on the only things i can figure it might be is the MAP sensor looks to have o-rings and the manual for some reason has you take it out to remove the manifold. Also one of the designs of the pcv system looks like it might have orings.

      might be those.


    5. #5
      What's wrong with my car?
      Join Date
      Jul 2014
      Location
      Maine
      Posts
      6
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Sorry, I should have also mentioned that at least 2 of them have thread marks, so they definitely went on somewhere bolted. I also didn't remove the MAP or PCV valve.

    6. #6
      Lifetime owner
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      8,010
      Garage empty: add car
      Thanks
      2
      Thanked 162 Times in 135 Posts
      your reusing them or they were new in the kit?






    Similar Threads

    1. 2005 Aveo 5-spd sedan - timing belt broke - being repaired
      By Daox in forum Photographs and Videos
      Replies: 252
      Last Post: 09-01-2018, 01:00 AM
    2. help! 911! timing belt broke, wont start now!
      By troy_mclure in forum Troubleshooting and Maintenance
      Replies: 8
      Last Post: 06-06-2014, 12:38 AM
    3. Replies: 1
      Last Post: 04-20-2013, 01:36 AM
    4. My Timing belt broke at a stop light while at an idle> DAMAGE????????????
      By belltroy in forum Troubleshooting and Maintenance
      Replies: 10
      Last Post: 06-02-2012, 05:21 AM
    5. parting out 2004 chevy aveo (timing belt broke)
      By stepj19 in forum For Sale / Wanted
      Replies: 30
      Last Post: 09-03-2011, 10:56 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •