•  
    Results 1 to 3 of 3

    Thread: Speedometer wonít work 2011 Aveo LT

    1. #1
      What's wrong with my car?
      Join Date
      Sep 2019
      Location
      New york
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Speedometer wonít work 2011 Aveo LT

      Hi all, my 2011 Aveo LT speedometer wonít work. I have replaced the output speed sensor and still nothing. I should note that I am getting a P0722 code but the weird thing is the TPMS light also flashes for about a minute then stays on. Iím a bit puzzled and not sure where to go from here. 8i notice no other issues with vehicle operation. Thank god for Waze so I can see how fast Iím going. Any ideas?



    2. #2
      I'll keep it and add a turbo
      Join Date
      Apr 2011
      Location
      California
      Posts
      188
      Thanks
      3
      Thanked 22 Times in 21 Posts
      TPMS flashing for a minute and remaining on indicates a problem with the TPMS system. Most likely just a sensor not communicating.
      The senders in the tires have coin-cell style batteries in them that should last about ~10 years before it runs out of juice. Check your tire pressures regularly, and maybe consider replacing them the next time you get new tires.

      Regarding the OSS code, it's probably time to start tracing wires from the sensor and checking continuity.
      Last edited by EAD15; 09-09-2019 at 12:22 AM.

    3. #3
      Should I keep it?
      Join Date
      Mar 2015
      Location
      SC
      Posts
      75
      Garage empty: add car
      Thanks
      0
      Thanked 4 Times in 4 Posts
      Check the wiring/connector if there's a signal from the output speed sensor.



    Similar Threads

    1. Aveo 2011 LT New Coil doesn't work but old one work
      By amrgym in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 03-10-2019, 06:16 AM
    2. 2011 Chevy Aveo Radio won't work
      By ekelsay in forum Audio, Video & Interior
      Replies: 0
      Last Post: 08-24-2017, 02:01 AM
    3. Help! Clutch and brake won't depress car won't start
      By Shrimmm1 in forum Introductions
      Replies: 2
      Last Post: 03-01-2015, 07:31 PM
    4. Wiper intermittent and park won't work
      By abby in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 12-29-2013, 07:42 PM
    5. Electric door locks won't work
      By weldboy in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 01-16-2013, 02:59 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •