•  
    Results 1 to 4 of 4

    Thread: Check Engine Light not coming on

    1. #1
      What's wrong with my car?
      Join Date
      May 2021
      Location
      Katy, Tx
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Check Engine Light not coming on

      Hello Aveo pals,
      The check engine light in my 2007 MT hatch has not been working for a while. I recently went to get it inspected in Texas and the new rules say that the CEL has to work to pass inspection, not just that no codes are shown. I have a scanner tool so I know when there are codes or not and if the ECU is showing a CEL (or MIL). So I pulled the throttle sensor connector out to cause a code that would make the CEL come on and it did not. I used the scanner and it showed multiple codes and that the CEL should be on. I removed the clock assembly and examined the bulbs and they looked fine. Also, very curiously I found a used clock assembly for sale on eBay and it stated that replacing the clock would not fix the CEL issue. So I wanted to see if anyone else has had a similar issue before I try replacing the clock anyways.



    2. #2
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      247
      Thanks
      0
      Thanked 19 Times in 19 Posts
      Quote Originally Posted by Joshwakw View Post
      Also, very curiously I found a used clock assembly for sale on eBay and it stated that replacing the clock would not fix the CEL issue. So I wanted to see if anyone else has had a similar issue before I try replacing the clock anyways.
      I've not heard that one before. If the ecm is calling for the money light to be on, the clock module shouldn’t be able to make any decisions on its own (unless it’s defective and can’t light up).
      personally, I’d slap another clock in there and see what happens (it’ll probably work).

    3. #3
      What's wrong with my car?
      Join Date
      May 2021
      Location
      Katy, Tx
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Update: went to the junkyard and scavanged a new clock and few other unrelated parts. Put the new clock in and BAM, CEL fixed. I assume then what the eBay seller meant was that replacing the clock would not turn the CEL off if it was on, not the other way around like was my problem.

    4. #4
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      247
      Thanks
      0
      Thanked 19 Times in 19 Posts
      Glad it worked out.





    Similar Threads

    1. 2005 aveo, check engine light And "Hold" light flashing...
      By azaveo in forum Engine & Drivetrain
      Replies: 50
      Last Post: 05-09-2017, 03:35 PM
    2. Right brake light not coming on
      By Dvor in forum Troubleshooting and Maintenance
      Replies: 5
      Last Post: 09-30-2015, 12:30 AM
    3. car shuting off with no engine light or oil light coming on..
      By crazieladie79 in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 04-18-2015, 12:43 PM
    4. Need help with Check Engine Light.. (P0053 keeps coming back)
      By sweetcorrie in forum General Discussion
      Replies: 0
      Last Post: 10-21-2012, 06:23 PM
    5. Check Engine Light Flashes. dnt know where the Connector is to check
      By a1atif in forum Troubleshooting and Maintenance
      Replies: 4
      Last Post: 08-02-2011, 04:00 PM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •