•  
    Results 1 to 4 of 4

    Thread: Aveo blues!!! Shifter issues and temp issues!

    1. #1
      Should I keep it?
      Join Date
      Jan 2014
      Location
      texas
      Posts
      36
      Thanks
      1
      Thanked 0 Times in 0 Posts

      Angry Aveo blues!!! Shifter issues and temp issues!

      Had head gasket replaced put back together had coolant system flush using the flush from part store. Car temp goes up straight to half way mark and its been sitting still all night long. when running you can hear boilng or bubbling right behind the sterring wheel. When remove the cap from resevoir there is the milky stuff again sometimes the water stays green with the anitfreeze and then if test drive and come back the milky stuff is back ugghhh temp gauge never went up to the H it stays at half way so what can me making it still be hot Radiator/waterpump stopped up still?? Gessh this car is a pain in the buttt fa real. When you disconnect all the hoses from coolant system water comes out clear so something is seems to be still clogged up and pushing back into the reservoir when that happened it cause the transmission to not go into gear and now there is a huge leak coming from the transmission. Transmission was fine going into gear and everything when test drive and came back and open bottle milky substance came out and then it stop going into gear and transmission started leaking fluid all this some way has something to do with one another has to be. There is brake light when step on brakes button is super hard and it want release unless you use screw driver and push the releease button. Then on top of all this drama the engine light on with a code about some sensor on transmission maybe this sensor has lot to do with leak and shifter not coming outta park. LORD HELP ME!! ANY ONE ADVICE THANKS!



    2. #2
      Administrator Daox's Avatar
      Join Date
      Jan 2007
      Location
      Wisconsin
      Posts
      2,514
      Thanks
      170
      Thanked 87 Times in 76 Posts
      When you replaced the head gasket did you resurface the head and check to make sure the block was flat?

    3. #3
      Should I keep it?
      Join Date
      Jan 2014
      Location
      texas
      Posts
      36
      Thanks
      1
      Thanked 0 Times in 0 Posts
      head went to a machine shop to be checked and milled whatever that is the mechanic suggested. I had another mechanic look and he says its the oil coolant I maybe saying it wrong but its a part that separates the oil and coolant. He was underneath the vehicle with a flashlight. Do you know what he maybe referring to?

    4. #4
      What's wrong with my car?
      Join Date
      Sep 2020
      Location
      Chateauguay Quebec Canada
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      If the transmission is an automatic then the radiator is leaking into the transmission cooler(white substance).Repair or replace.





    Similar Threads

    1. 07 Aveo Startup issues
      By joshuah459 in forum Troubleshooting and Maintenance
      Replies: 3
      Last Post: 10-02-2015, 09:45 PM
    2. 09 Aveo - Just Purchased, Has Issues
      By crfiala in forum Troubleshooting and Maintenance
      Replies: 6
      Last Post: 09-09-2014, 08:54 AM
    3. 2005 Thermostat issues? Do they make a low temp one?
      By Burgman in forum General Discussion
      Replies: 25
      Last Post: 01-03-2013, 08:44 AM
    4. '04 Aveo Engine Issues
      By Konstantine in forum Engine & Drivetrain
      Replies: 42
      Last Post: 06-10-2011, 05:00 AM
    5. New Aveo, New Issues
      By AutoXChris in forum General Discussion
      Replies: 25
      Last Post: 05-31-2010, 05:22 PM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •