•  
    Results 1 to 2 of 2

    Thread: 2009 aveo engine no power

    1. #1
      What's wrong with my car?
      Join Date
      Oct 2022
      Location
      London
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      2009 aveo engine no power

      Hi All ,

      Hopefully someone might help .
      I have inherited this AVEO 1.4 manual stick as my first car which has an engine running issue .
      It starts fine but when you try to drive , the engine has no power . It struggles to reach 4000rpm and makes a strange sound coming back out of the airbox .
      No engine light .

      Any advice would be great .



    2. #2
      edk
      edk is offline
      What's wrong with my car?
      Join Date
      Jul 2013
      Location
      Warwick, RI
      Posts
      14
      Thanks
      0
      Thanked 0 Times in 0 Posts
      My 2009 automatic transmission did the same thing. It was a bad drive gear in the transmission. That plastic gears drives the vss or “ vehicle speed sensor “. The engine is a “drive by wire” system. The are no direct connections between the gas pedal and the throttle body. The computer relies on the vehicle speed to know how much fuel and timing to feed the engine.



    Similar Threads

    1. Replies: 4
      Last Post: 10-29-2020, 03:50 AM
    2. 2007 aveo, loss of power, rough idle, 6 engine codes.
      By Aveo driver in forum Technical
      Replies: 5
      Last Post: 08-12-2019, 01:09 AM
    3. Need help!!2004 Aveo power windows and power door locks stopped working
      By rockerjoey in forum Troubleshooting and Maintenance
      Replies: 1
      Last Post: 12-29-2015, 12:57 AM
    4. Replies: 3
      Last Post: 07-22-2015, 03:59 AM
    5. Replies: 2
      Last Post: 06-12-2015, 09:10 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •