•  
    Results 1 to 4 of 4

    Thread: 2007 Aveo LS Sedan - Whistle noise when going 70mph+ / windy days?

    1. #1
      What's wrong with my car?
      Join Date
      Feb 2022
      Location
      Tulsa, OK
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      2007 Aveo LS Sedan - Whistle noise when going 70mph+ / windy days?

      Heyo! I just have a quick question about the car

      My dad owns a 2007 Aveo LS Sedan, base model. We've had it for years now, but we've always had this weird whistling noise when we go interstate speeds, or on pretty windy days. We've gotten used to it, but I've always wondered what might be causing it. Anyone have any ideas, or maybe ideas on how to stop it? Not an urgent issue or really a need-to-fix, just curious

      I recorded an example vid of it tonight while on the highway, here's the vid below





    2. #2
      Should I keep it?
      Join Date
      Apr 2017
      Location
      Toronto
      Posts
      86
      Garage empty: add car
      Thanks
      0
      Thanked 16 Times in 13 Posts
      If you Google around, you can find others have had that same problem. It seems to be the rubber weatherstripping door seal, usually the driver's door. When a slight air gap happens in the rubber weatherstripping seal of the door, the wind rushing past that gap makes a whistling noise. One suggestion I saw from someone involves installing extra self-adhesive weatherstripping beside the existing weatherstipping. You can buy that weatherstripping at Lowes or other big hardware stores. Other suggestions involve adjusting the door striker mechanism, so that the door and existing weatherstripping seats more fully when closed.

      Deano

    3. #3
      Should I keep it?
      Join Date
      Sep 2021
      Location
      Spain
      Posts
      56
      Thanks
      7
      Thanked 1 Time in 1 Post
      I like the dials.. I'm guessing those aren't original, right?

      EDIT: I have been looking around, and I have seen it's the original dashboard for that version...
      Last edited by Enxebre; 02-12-2022 at 08:59 PM.

    4. #4
      What's wrong with my car?
      Join Date
      Feb 2022
      Location
      Tulsa, OK
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Quote Originally Posted by Enxebre View Post
      I like the dials.. I'm guessing those aren't original, right?

      EDIT: I have been looking around, and I have seen it's the original dashboard for that version...
      It's the original, seems like the sedan & hatch have different gauge clusters

      Quote Originally Posted by Deano View Post
      If you Google around, you can find others have had that same problem. It seems to be the rubber weatherstripping door seal, usually the driver's door. When a slight air gap happens in the rubber weatherstripping seal of the door, the wind rushing past that gap makes a whistling noise. One suggestion I saw from someone involves installing extra self-adhesive weatherstripping beside the existing weatherstipping. You can buy that weatherstripping at Lowes or other big hardware stores. Other suggestions involve adjusting the door striker mechanism, so that the door and existing weatherstripping seats more fully when closed.

      Deano
      Oh weird, I'll give this a look when I get the chance. I thought it was the mirrors or door handles causing the whistle, but it being the door gap is definitely interesting. Thanks





    Similar Threads

    1. Replies: 7
      Last Post: 12-23-2020, 08:22 PM
    2. 8 days old...no nickname yet :: 2011 Chevrolet Aveo LT (Garage entry)
      By MetroMPG in forum Members' Aveos / Garages
      Replies: 0
      Last Post: 12-18-2014, 03:21 PM
    3. Replies: 8
      Last Post: 01-16-2014, 07:45 AM
    4. 2011 Aveo will not crank on cold days (typically below 30-deg F)
      By shubee2 in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 01-03-2014, 09:09 PM
    5. Going on a trip in 2 days, just curious on these images of my engine.
      By TechGeddon in forum Troubleshooting and Maintenance
      Replies: 6
      Last Post: 11-09-2013, 11:47 AM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •