•  
    Results 1 to 3 of 3

    Thread: Aveo Problems

    1. #1
      What's wrong with my car?
      Join Date
      Mar 2015
      Location
      United States
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Aveo Problems

      Hi All,

      First time post and I apologize if this is in the wrong spot. My wife has a 2009 Aveo and this last week the hold light start flashing, it has since stopped blinking but now the temperature gauge and the A/C works on and off. I thought that it could be the thermostat and considered changing it and I've also read that it could be as simple as the battery is not properly grounded to the frame. If anyone could give me advice it would be appreciated! Thanks!



    2. #2
      Still love my daily driver
      Join Date
      Feb 2014
      Location
      pa
      Posts
      800
      Garage empty: add car
      Thanks
      0
      Thanked 10 Times in 10 Posts
      if the check engine light is blinking that means you have a misfire

    3. #3
      What do you mean there's no turbo? PoisonIvy's Avatar
      Join Date
      Mar 2013
      Location
      Canada
      Posts
      393
      Thanks
      10
      Thanked 56 Times in 49 Posts
      The temp gauge dropping out along with the computer shutting down the a/c as a precaution, is a common GM issue when the thermostat goes bad. That's what I'd recommend changing. I've read to stick with the oem part on this, but it's up to you.



    Similar Threads

    1. My Aveo Has Problems. (sputtering, hold light, check engine light)
      By kdr315 in forum Troubleshooting and Maintenance
      Replies: 20
      Last Post: 11-27-2015, 01:41 PM
    2. Replies: 4
      Last Post: 09-07-2015, 03:41 AM
    3. 06 Aveo ls, new problems
      By Jaxman in forum Wheels, Tires, Brakes & Suspension
      Replies: 0
      Last Post: 11-10-2013, 03:24 PM
    4. Carkit problems aveo 2011
      By sanderman123 in forum Troubleshooting and Maintenance
      Replies: 1
      Last Post: 12-21-2011, 11:53 AM
    5. My Aveo problems
      By Jason2009 in forum Troubleshooting and Maintenance
      Replies: 6
      Last Post: 10-05-2010, 08:49 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •