•  
    Results 1 to 7 of 7

    Thread: Wierd smell when using Air Conditioner

    1. #1
      Chevrolet Aveo 09 LS (KR) ChevyCC's Avatar
      Join Date
      Nov 2012
      Location
      Tegucigalpa,Honduras
      Posts
      46
      Thanks
      0
      Thanked 8 Times in 7 Posts

      Wierd smell when using Air Conditioner

      Hello,

      (09 Aveo with 55,000km SOHC 1.5L)

      Air conditioner works fine, I replace cabin air filter every 20,000kms, the problem is that from time to time, while using A/C (after 10 -15 min) a wierd smell appears for a while (5 min or so) and goes away.

      I googled it, and they say its due to "mold build up in the air ducts or so"

      maybe someone has encountered this and has solved it.

      Thanks for your replies & suggestions.



    2. #2
      Almost time to do my timing belt xintersecty's Avatar
      Join Date
      Sep 2010
      Location
      West Union, SC
      Posts
      1,687
      Thanks
      86
      Thanked 179 Times in 156 Posts
      The one thing I would check the is the drain hole from the evaporator (inside car) and make sure it's not blocked.
      Please do not power off, firmware update pending.....

    3. #3
      Chevrolet Aveo 09 LS (KR) ChevyCC's Avatar
      Join Date
      Nov 2012
      Location
      Tegucigalpa,Honduras
      Posts
      46
      Thanks
      0
      Thanked 8 Times in 7 Posts
      Quote Originally Posted by xintersecty View Post
      The one thing I would check the is the drain hole from the evaporator (inside car) and make sure it's not blocked.
      When so say inside, its behind glove box ?
      I guess theres meant to be a collector or drip pan of some sort that discharges through little hose/pipe (1/4") to side of engine

    4. #4
      Almost time to do my timing belt xintersecty's Avatar
      Join Date
      Sep 2010
      Location
      West Union, SC
      Posts
      1,687
      Thanks
      86
      Thanked 179 Times in 156 Posts
      Quote Originally Posted by ChevyCC View Post
      When so say inside, its behind glove box ?
      I guess theres meant to be a collector or drip pan of some sort that discharges through little hose/pipe (1/4") to side of engine
      Exactly. I have not personally done this on an Aveo. I just know it has to be there. I have tubing like that clog up and molded. The other easy check is to run the AC and just see if it drips out.
      Please do not power off, firmware update pending.....

    5. #5
      Chevrolet Aveo 09 LS (KR) ChevyCC's Avatar
      Join Date
      Nov 2012
      Location
      Tegucigalpa,Honduras
      Posts
      46
      Thanks
      0
      Thanked 8 Times in 7 Posts
      OK, I will have a look & will be taking some pics in case thats the problem. Thanks for your suggestion.

    6. #6
      What do you mean there's no turbo? PoisonIvy's Avatar
      Join Date
      Mar 2013
      Location
      Canada
      Posts
      393
      Thanks
      10
      Thanked 56 Times in 49 Posts
      There's sprays that are supposed to help with this. I've never had it happen bad enough to need them myself.

      I've always tried to turn the a/c off as I got close to the destination. Running just the vent for a short period is 'supposed' to help clear out some of the moisture from running the a/c.

    7. #7
      Chevrolet Aveo 09 LS (KR) ChevyCC's Avatar
      Join Date
      Nov 2012
      Location
      Tegucigalpa,Honduras
      Posts
      46
      Thanks
      0
      Thanked 8 Times in 7 Posts
      Quote Originally Posted by PoisonIvy View Post
      There's sprays that are supposed to help with this. I've never had it happen bad enough to need them myself.

      I've always tried to turn the a/c off as I got close to the destination. Running just the vent for a short period is 'supposed' to help clear out some of the moisture from running the a/c.
      I read somewhere that spraying some Lysol should do. The question is, where to spray exactly?





    Similar Threads

    1. air conditioner not blowing cold on 2009 Aveo LT5 automatic
      By Felix C in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 09-26-2014, 04:43 AM
    2. Gas smell in car
      By TxBandit in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 07-18-2014, 02:52 PM
    3. Air Conditioner Issues - 2010 Chevy Aveo LT
      By Interstate275Fla in forum Troubleshooting and Maintenance
      Replies: 4
      Last Post: 09-09-2013, 03:45 PM
    4. wierd 3 1/2 gear
      By ajk148700 in forum Engine & Drivetrain
      Replies: 0
      Last Post: 10-26-2012, 02:23 AM
    5. A/C smell comes and goes
      By INERTIA in forum Troubleshooting and Maintenance
      Replies: 1
      Last Post: 07-06-2011, 01:22 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •