•  
    Results 1 to 4 of 4

    Thread: Temperature gauge stop working

    1. #1
      What's wrong with my car?
      Join Date
      Oct 2020
      Location
      Hull, MA
      Posts
      7
      Thanks
      2
      Thanked 0 Times in 0 Posts

      Temperature gauge stop working

      Hi, my 2009 Chev Aveo5 176K miles temperate gauge stop working, idk why. I got in the hwy, 22 miles straight, the needles dropped to Botton and its there... help



    2. #2
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      245
      Thanks
      0
      Thanked 19 Times in 19 Posts
      Name:  862FF6D5-98DE-4D4E-8159-A8F898AF8D73.jpg
Views: 58
Size:  211.6 KB
      possible remedy.

    3. #3
      I'll keep it and add a turbo
      Join Date
      Apr 2011
      Location
      California
      Posts
      236
      Thanks
      4
      Thanked 32 Times in 31 Posts
      I had that happen to me. In my case, I pulled a pending code that pointed to the thermostat being stuck open. Regardless, it's either the sender as Eg mentioned, or the thermostat got stuck and set a code.

      I can say from experience it's just easier to replace the thermostat/sender assembly as a unit on the 09 models (that's how the thermostat is usually sold, anyway). I had to replace my thermostat and decided to see if I could keep the sensor but it was thoroughly stuck. Ended up destroying it just trying to get it out.
      https://www.rockauto.com/en/moreinfo...t=2200&jsn=965

    4. #4
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      245
      Thanks
      0
      Thanked 19 Times in 19 Posts
      Agreed. I’d change the whole unit now that I think about it.





    Similar Threads

    1. Replies: 0
      Last Post: 03-31-2021, 08:47 AM
    2. 2009 Aveo temperature gauge not working, fixed
      By Bruno59 in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 10-16-2017, 06:51 PM
    3. installing a transmission oil temperature gauge (manual trans)
      By northguest47 in forum Engine & Drivetrain
      Replies: 27
      Last Post: 06-04-2016, 12:35 AM
    4. Flashing hold light-no a/c-dead temperature gauge
      By pavilion780n in forum Troubleshooting and Maintenance
      Replies: 8
      Last Post: 10-16-2014, 04:41 PM
    5. Replies: 8
      Last Post: 12-06-2013, 10:11 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •