•  
    Results 1 to 4 of 4

    Thread: Speedometer, Tach, temp and fuel gauge stopped working but inst. panel lights work

    1. #1
      What's wrong with my car?
      Join Date
      Nov 2021
      Location
      Indiana
      Posts
      6
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Speedometer, Tach, temp and fuel gauge stopped working but inst. panel lights work

      We recently bought a 2007 Aveo LS for our son (75,000 miles). This is our 3rd Aveo, and we've had great luck with the other 2 (2004 with 80,000, and 2008 Aveo5 w/ 120,000). It seemed to be in good condition. Since we've had it (a few weeks) the cam position sensor went out (we replaced it). Then my son called me and said that his key was stuck and it wouldn't go into gear. We had this issue w/ my daughter's (brake transaxle something-or-other). So I order the part to fix this.

      In the meantime, I read where we could take out the RADIO/CLOCK fuse to get the key to release. We did that, and got the key out. I restarted it and realized several other things are now not working (even with the fuse replaced). All 4 gauges don't work, the radio doesn't work (clock does), and the OBDII connection doesn't work either. The OBDII was working--I read the code to see that the cam position sensor was bad. I checked by OBDII bluetooth device on my car, and it works like a charm. It just doesn't work on my son's.

      I pulled several fuses that I thought might have something to do with the instrument panel, but they all looked fine (I didn't check continuity on them--my voltmeter was at work).

      Anyways, anyone have any ideas on what I should check. It seems most searches on the internet don't have all of the same issues. I'm at a loss as to where to start. The shift interlock solenoid will be in on Thursday, but I didn't figure it would cause all of these problems. I appreciate any help! Thanks!



    2. #2
      What's wrong with my car?
      Join Date
      Nov 2021
      Location
      Indiana
      Posts
      6
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Anybody have any suggestions?

    3. #3
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      253
      Thanks
      0
      Thanked 21 Times in 20 Posts
      Everything that’s not working seems to be a key “on” situation. Check for power at the ignition switch. I think one of your 3 or 4? larger gauge wires is not getting power when the key should activate it.

    4. #4
      What's wrong with my car?
      Join Date
      Nov 2021
      Location
      Indiana
      Posts
      6
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Quote Originally Posted by Eg.h2o View Post
      Everything that’s not working seems to be a key “on” situation. Check for power at the ignition switch. I think one of your 3 or 4? larger gauge wires is not getting power when the key should activate it.
      Then I'm hoping that it has something to do with the brake-transaxle part that I'm putting on. I know that it's keeping the key from coming out, and hopefully it's all tied together. I'm switching that part out tomorrow. If that doesn't solve the issues, I'll start with what you mentioned. Thanks!





    Similar Threads

    1.  HOLD light flashing, temp gauge and a/c not working.
      By Babette in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 05-12-2018, 11:28 PM
    2. HOLD light flashing, temp gauge and a/c not working.
      By Babette in forum General Discussion
      Replies: 0
      Last Post: 05-12-2018, 11:23 PM
    3. 2009 Aveo5 P0128, temp gauge and A/C not working
      By SilentMatt in forum Technical
      Replies: 5
      Last Post: 10-07-2016, 05:51 AM
    4. Quick Question (AC & temp gauge intermittently do not work)
      By FireTalon in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 05-03-2013, 11:10 PM
    5. radio/lights stopped working
      By ginger in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 10-13-2011, 09:37 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •