•  
    Results 1 to 3 of 3

    Thread: Several error codes...

    1. #1
      What's wrong with my car?
      Join Date
      Nov 2018
      Location
      Seattle
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Angry Several error codes...

      Hello,

      I am driving a 2006 Chevy Aveo LS. The other day it shuddered a lot, and entered “limited power” mode and the engine light came on shortly after I turned the car on. The vehicle has been idling kinda rough for a few months now, but nothing too crazy. I took the car to Autozone and they told me that the error codes it gave them were:
      P2106
      P2110
      P161b
      P0106

      About a month ago, the car did the exact same thing and gave error code P161b. The folks at Autozone said that I needed a new battery, so I dropped $220 on that... The car ran just fine after that, all the way up until a couple of days ago.

      I looked at my throttle body, and it was pretty dirty and it wasn’t opening at all when the accelerator was pressed. I tried cleaning it with the recommended solvent, but I was having a hard time reaching in there and I didn’t have much time to really try to clean it properly. I’m going to try cleaning it properly soon, once I get the chance.

      What else needs to be done here? I realize that without the throttle body functioning properly, the engine has no hope of getting enough oxygen to burn its fuel, and will therefore not work. I am super broke right now, and can not afford a new gasket if I were to remove the throttle body for cleaning.

      Any advice would be muchly appreciated!




    2. #2
      Almost time to do my timing belt
      Join Date
      Aug 2012
      Location
      Northeast
      Posts
      1,290
      Thanks
      3
      Thanked 95 Times in 87 Posts
      Quote Originally Posted by Obligatoryuser View Post
      ... I am super broke right now, and can not afford a new gasket if I were to remove the throttle body for cleaning. ...
      Unfortunately you paid around $100 more than necessary for the battery, so you might want to do some comparison shopping in the future. Check the MAP sensor connector tube, and use tape temporarily to patch any cracks found. If the tube is ok, then there's a good chance the MAP sensor is going bad.

    3. #3
      What's wrong with my car?
      Join Date
      Nov 2018
      Location
      Seattle
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Yeah, I shopped around a bit online, but I kinda felt like I was being ripped off for that battery.

      Turns out you were right, there was a small vacuum tube that had cracked near the MAP sensor. Thanks!



    Similar Threads

    1. Grinding noise after changing drums/bearings several times
      By Andrew_Molina in forum Wheels, Tires, Brakes & Suspension
      Replies: 1
      Last Post: 08-23-2017, 02:13 PM
    2. 2006 Aveo, CD Player Error Messages...What are they? Error7, Error 9.
      By FlaAveo5 in forum Audio, Video & Interior
      Replies: 0
      Last Post: 08-14-2017, 06:53 PM
    3. Retrieving error codes from ECU?
      By jalucerol in forum How-To
      Replies: 5
      Last Post: 05-25-2013, 12:21 PM
    4. Check Engine Light - 4 Error Codes - Please Advise!
      By mayberry97 in forum Engine & Drivetrain
      Replies: 6
      Last Post: 03-15-2011, 09:45 PM
    5. Aveo-rough idle-no error codes
      By points_north in forum Troubleshooting and Maintenance
      Replies: 3
      Last Post: 06-22-2010, 12:32 PM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •