•  
    Results 1 to 4 of 4

    Thread: I have a problem with A/C.

    1. #1
      What's wrong with my car?
      Join Date
      Jul 2015
      Location
      LA
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Question I have a problem with A/C.

      Hi guys, It has been about 3 weeks since I bought 2009 Aveo LT(with manual lock and window) as my first vehicle.
      I bought it very quickly without having enough time to inspect any problems. I was not very patient.
      While I drove it to my apt, I found that the A/C was not blowing cold air. So I brought it to a certified A/C mechanic. He said the expansion valve seemed to be clogged. We replaced it, then it got better but started to blow hot air again. He said the previous owner probably used the recharging can which contains some kind of chemical that causes clogging the system. We tried to clean the new expansion valve and it got better(best condition so far). It now gives "cool" air HOWEVER I need to drive for more than 5 minutes to get cool air and it is just not cool enough. A/C should be blowing "COLD" air but mine just blows cool air which just can't decrease the temperature of the inside.

      I live in Southern California and hate the super strong sunlight. I really want an A/C that works perfect. If any of you could give me just a little help, I would be very thankful.
      Sorry for my poor English.
      Thank you for reading and sharing your thoughts.


      Last edited by anynose; 07-21-2015 at 11:44 AM.

    2. #2
      What's wrong with my car?
      Join Date
      Jul 2010
      Posts
      16
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Can you take your car back to the certified mechanic that fixed your car and ask him to measure the pressures on the low and high lines and post the readings? He should you do it for you for free.

    3. #3
      here from Spain
      Join Date
      Feb 2012
      Location
      Salamanca, Spain
      Posts
      20
      Thanks
      0
      Thanked 2 Times in 2 Posts
      If the pressures are OK, check the ambient temperature sensor, on the front, behind the grill.

    4. #4
      Should I keep it?
      Join Date
      Jan 2017
      Location
      New Jersey
      Posts
      33
      Garage empty: add car
      Thanks
      3
      Thanked 0 Times in 0 Posts
      It takes about 5-10 minutes to get COLD air with my 188k-miles car, so maybe thats normal for a cheap car or a weak compressor? But then again I jerry-rigged my car to make it work lol

      For me, at roughly 70F, the A/C takes less than 5 minutes while driving, but above 75F, especially above 90F, it takes 5-10 minutes while driving.





    Similar Threads

    1. A/C problem
      By cjjessie79 in forum Troubleshooting and Maintenance
      Replies: 12
      Last Post: 09-09-2015, 02:09 AM
    2. Clock problem and Airbag light problem
      By sbelcher in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 03-05-2015, 10:55 PM
    3. Problem in the A/C
      By hussien ali in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 09-19-2014, 06:16 AM
    4. Replies: 10
      Last Post: 08-31-2013, 06:05 PM
    5. Problem!!!!!
      By Anthony0903 in forum Troubleshooting and Maintenance
      Replies: 9
      Last Post: 10-04-2011, 04:51 AM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •