•  
    Results 1 to 2 of 2

    Thread: Front Driver Side Rubbing/scraping sound.

    1. #1
      What's wrong with my car?
      Join Date
      Jan 2020
      Location
      Appleton
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Post Front Driver Side Rubbing/scraping sound.

      I have a 2007 Aveo5, manual. I have just developed a weird rubbing noise that a mechanic friend of mine thinks could just be a small stone/piece of sand lodged in by my break pad. It's mostly when i take left turns, but sounds pretty brutal when I'm breaking.
      I got the car from my Grandpa, who bought it from the dealership brand new.

      Any advice/suggestions?

      The wheel bearings were changed at 150k miles. I currently have 194k miles on it.



    2. #2
      Should I keep it?
      Join Date
      Mar 2015
      Location
      SC
      Posts
      88
      Garage empty: add car
      Thanks
      0
      Thanked 5 Times in 5 Posts
      Try spraying some grease on the sway bar bushings.



    Similar Threads

    1. Roaring / vibrating in front end (driver side) - 2007 Aveo LS
      By mexitydye in forum Troubleshooting and Maintenance
      Replies: 4
      Last Post: 12-17-2014, 04:18 AM
    2. Replies: 21
      Last Post: 08-23-2014, 01:20 AM
    3. Needing a LS front driver side door shell
      By djmarch in forum For Sale / Wanted
      Replies: 0
      Last Post: 02-17-2014, 11:20 PM
    4. Metal-on-metal screeching (scraping) sound when hitting bumps, coming from rear area
      By mexitydye in forum Troubleshooting and Maintenance
      Replies: 4
      Last Post: 01-31-2012, 09:14 PM
    5. Scraping sound, in the motor area?
      By EliSprague in forum Troubleshooting and Maintenance
      Replies: 3
      Last Post: 04-06-2011, 08:25 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •