•  
    Page 1 of 2 12 LastLast
    Results 1 to 10 of 13

    Thread: electrical problems and ecu (won't start; cluster going crazy even with key out)

    1. #1
      What's wrong with my car?
      Join Date
      Oct 2015
      Location
      Canada
      Posts
      4
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Exclamation electrical problems and ecu (won't start; cluster going crazy even with key out)

      I have a 2008 aveo LT and the car just quit on me the car turns over but it do not strat with no key in the ignition all the lights in the dash are on and the cluster needles going up and down the car is going crazy lol WHAT DO I DO I put a scan tool on it and the car powers it off and on fast like the power is surging off and on fast if I put the brack peddle down it's stop the power lights go out under the hood the fuse box clicks off and on and I the the thottle body going off and on



    2. #2
      Almost time to do my timing belt
      Join Date
      Aug 2012
      Location
      Northeast
      Posts
      1,270
      Thanks
      3
      Thanked 93 Times in 85 Posts
      Has anything been done recently - any repairs or maintenance? Have you put a multi-meter (or better yet a battery tester) on the battery to check the voltage before, and while it's cranking?

    3. #3
      Administrator MetroMPG's Avatar
      Join Date
      Jan 2007
      Location
      1000 Islands, Ontario, Canada
      Posts
      4,039
      Thanks
      239
      Thanked 113 Times in 95 Posts
      the lights in the dash are on and the cluster needles going up and down the car is going crazy lol
      Wow. Sounds like your car is celebrating Hallowe'en early by being "posessed".

      Sorry... not helpful.

    4. #4
      Aveo Whisperer 06T200's Avatar
      Join Date
      Aug 2014
      Location
      530
      Posts
      616
      Thanks
      55
      Thanked 85 Times in 73 Posts
      I have seen this, but only when I had left the ground bolt under the battery loose on accident, and the ground was 'sort of' making contact. Or could be the battery going out. Either way seems like a main power issue to see everything cycle on and off.

    5. #5
      What's wrong with my car?
      Join Date
      Oct 2015
      Location
      Canada
      Posts
      4
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      All take a look at all the grounds see if there all making contact I have a new battery I hope it's not the ECU

    6. #6
      Should I keep it?
      Join Date
      Oct 2015
      Location
      Burna, KY
      Posts
      40
      Thanks
      1
      Thanked 4 Times in 2 Posts
      I agree on main power source problem. But doubt it's a battery. Fuses and relays stop the batterys' power from reaching the systems to turn them off and on

    7. #7
      Should I keep it?
      Join Date
      Oct 2015
      Location
      Burna, KY
      Posts
      40
      Thanks
      1
      Thanked 4 Times in 2 Posts
      My Aveo is older than yours, so not familiar with the electrical setup. Does this one have a large fuse on the positive post? Could be shorting out and not stopping power once the car is shut off. Could also short on startup not allowing the fuel pump to run?

    8. #8
      Aveo Whisperer 06T200's Avatar
      Join Date
      Aug 2014
      Location
      530
      Posts
      616
      Thanks
      55
      Thanked 85 Times in 73 Posts
      Why would the ECU be bad? Were there any symptoms leading up to this point? or just died cold as you were driving.?

      bad grounds are 10/1 it seems, do the free stuff before eating the cost of an ECU. if you can.

    9. #9
      What's wrong with my car?
      Join Date
      Jan 2018
      Location
      Pennsylvania
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Not to bring back the dead, but did you ever find what the problem was? I’m haveing the exact same problem with my 2007 LT

    10. #10
      Should I keep it?
      Join Date
      Sep 2016
      Location
      Canada
      Posts
      63
      Garage empty: add car
      Thanks
      0
      Thanked 11 Times in 9 Posts
      The gauges, on 2010 model, can go crazy for 5-10 seconds if battery is dead.





    Page 1 of 2 12 LastLast

    Similar Threads

    1. Electrical problems
      By nvterp in forum Troubleshooting and Maintenance
      Replies: 1
      Last Post: 06-28-2013, 03:42 PM
    2. Strange and Sudden Electrical Problems
      By web in forum Troubleshooting and Maintenance
      Replies: 3
      Last Post: 11-13-2012, 10:59 AM
    3. Aveo 2007 goes crazy - Electrical
      By chihuahua2222 in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 10-10-2011, 05:05 PM
    4. Electrical/sensor problems? Dome light, clock, open-door light....
      By porkchop in forum Troubleshooting and Maintenance
      Replies: 5
      Last Post: 10-02-2011, 05:42 PM
    5. Aveo SS - Crazy Talk or Crazy Fun?
      By n0k in forum General Discussion
      Replies: 8
      Last Post: 03-24-2008, 05:20 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •