•  
    Results 1 to 4 of 4

    Thread: 2009 Aveo5 Lt, overheat on highway

    1. #1
      What's wrong with my car?
      Join Date
      Oct 2020
      Location
      Hull, MA
      Posts
      6
      Thanks
      2
      Thanked 0 Times in 0 Posts

      2009 Aveo5 Lt, overheat on highway

      Help: I forgot to check the coolant before go to work, drove 28 miles and the temp needle went up to the red... I was at the highway, so I drove to the next exit and them the power steering stiffed, battery-brakes-oil maintenance lights went off. I stopped (was hard to drive) put a little coolant I had, wait 20 min... turn on and the lights were there and the stiffed wheel too. I stopped at Autozone, got coolant, wait for 1 hour... nothing better. Towed the car home. Tried today in the morning, the wheel still stiffed. I canít figure it out whatís going on... dies anyone here has any clue?



    2. #2
      What's wrong with my car?
      Join Date
      May 2011
      Location
      Kiel, Wisconsin
      Posts
      4
      Garage empty: add car
      Thanks
      0
      Thanked 1 Time in 1 Post
      It sounds like your serpentine belt broke or the tensioner is not keeping proper belt tension. Therefore, the power steering pump, water pump, alternator are not turning.

    3. The Following User Says Thank You to buvdog87 For This Useful Post:

      marymoon (10-20-2020)

    4. #3
      What do you mean there's no turbo?
      Join Date
      Jun 2014
      Location
      Long Island, NY
      Posts
      298
      Thanks
      0
      Thanked 45 Times in 43 Posts
      Quote Originally Posted by buvdog87 View Post
      It sounds like your serpentine belt broke or the tensioner is not keeping proper belt tension. Therefore, the power steering pump, water pump, alternator are not turning.
      This is exactly what I was going to say^^
      2004 Aveo beater car
      2005 Aveo LT. 5-speed beater car (DOA)

    5. The Following User Says Thank You to slayerized6 For This Useful Post:

      marymoon (10-20-2020)

    6. #4
      What's wrong with my car?
      Join Date
      Oct 2020
      Location
      Hull, MA
      Posts
      6
      Thanks
      2
      Thanked 0 Times in 0 Posts
      Quote Originally Posted by buvdog87 View Post
      It sounds like your serpentine belt broke or the tensioner is not keeping proper belt tension. Therefore, the power steering pump, water pump, alternator are not turning.
      That is correct... fixed!!
      Now there is a knock sound coming from the engine.





    Similar Threads

    1. 05 Aveo LS Overheat/Fan/Relay
      By ThatGuy8432 in forum Technical
      Replies: 0
      Last Post: 07-24-2016, 05:10 PM
    2. 2006 trying to overheat
      By ToriRyuzaki in forum Troubleshooting and Maintenance
      Replies: 9
      Last Post: 04-05-2014, 03:00 PM
    3. Replies: 14
      Last Post: 03-22-2014, 10:31 PM
    4. Strange coolant loss, random overheat.
      By black75dog in forum Troubleshooting and Maintenance
      Replies: 9
      Last Post: 09-21-2013, 02:31 PM
    5. my new highway yellow 2009 Aveo5
      By flaveo5 in forum Photographs and Videos
      Replies: 62
      Last Post: 07-29-2009, 07:43 AM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •