•  
    Results 1 to 1 of 1

    Thread: New to me car, and hello

    1. #1
      2004 1.6 Auto Rust Free
      Join Date
      Jun 2019
      Location
      NC
      Posts
      74
      Thanks
      0
      Thanked 6 Times in 6 Posts

      New to me car, and hello

      Recently bought a new to us 2004 Aveo 1.6 auto sedan with 124,xxx miles. Being from inland NC, it has no rust. With its age, it needed lots of love. So far in the last 2 months, I’ve put on:

      remanufactured head

      full timing belt set with water pump

      valve cover gasket

      serpentine belt and tensioner

      every coolant hose (yes, all of them)

      spark plugs and wires

      loaded front struts

      o-rings on the A/C compressor (A/C is NOT optional around here)

      automatic transmission front pump seal (torque converter seal)

      OEM fuel cap, and no it didn’t fix the P0455 code. All three EVAP sensors tested good. I guess I have to start tracing emission hoses and the fuel tank rubber

      I expect to drive this car for many years, so i don’t mind making the needed repairs. I've started a couple new threads for help with what I have left to do. Help me if you can.





      Last edited by Eg.h2o; 06-10-2019 at 01:58 AM. Reason: grammar

    Similar Threads

    1. Hello and presenting my car electric AVEO
      By techno02 in forum Introductions
      Replies: 0
      Last Post: 11-21-2018, 07:06 PM
    2. Hello all new here and question
      By Sid1971 in forum Introductions
      Replies: 0
      Last Post: 02-15-2018, 02:54 PM
    3. Replies: 9
      Last Post: 09-07-2015, 05:48 PM
    4. Replies: 3
      Last Post: 08-27-2014, 03:46 PM
    5. Hello, I'm new, and I have questions...
      By jim84 in forum General Discussion
      Replies: 16
      Last Post: 12-19-2012, 12:50 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •