• AveoForum decals - get one free, or buy
    Page 1 of 4 123 ... LastLast
    Results 1 to 10 of 39

    Thread: 2005 aveo, check engine light And "Hold" light flashing...

    1. #1
      Junior Member
      Join Date
      Nov 2011
      Location
      Arizona
      Posts
      7

      2005 aveo, check engine light And "Hold" light flashing...

      Hey,
      i have a 2005 aveo that is giving me issues. the check engine light is flashing (p0300, random misfire. i checked/cleaned/regaped the plugs) check the wires and connections, everything looks good, no vacuum leaks that i see, egr seems ok), and i also at the same time have the "Hold" light flashing, and when it does so...the tranny will not shift into 4th gear, it just stays in 3rd. however when the hold light doesn't flash the tranny shifts smooth and fine into 4th.

      this is my first aveo....any idea's?


      Attached Images Attached Images  

    2. #2
      Senior Member
      Join Date
      Nov 2011
      Location
      chattanooga
      Posts
      125
      What do you mean by "looks good"? Do you mean you visually inspected them, tested them, or replaced them? I've had plugs and wires that visually looked good but later proved to be malfunctioning and had to replaced.

    3. #3
      Junior Member
      Join Date
      Nov 2011
      Location
      Arizona
      Posts
      7
      i was referencing visually (as it was still light out), that evening i gave the wires a shower...it was a mini lightening show. could wires cause both the p0300 AND the HOLD light to flash though? i know yes to the p0300 but i don't see how the hold light (thus transmission) would be effected by an ignition issue?

    4. #4
      Senior Member
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      6,973
      Garage empty: add car
      yes, misfire of the coilpack can cut the rpm signal to the transmission ecu.

      do the coilpack and wires.


    5. #5
      Junior Member
      Join Date
      Nov 2011
      Location
      Arizona
      Posts
      7
      have other people experienced this issue? i can't afford to throw parts at it and find out that wasn't the issue.

    6. #6
      Senior Member
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      6,973
      Garage empty: add car
      i have directed a few people to that as the problem.

      to under simplify the issue, put start the car and mist the coil pack with water, if you see sparks, its arcing out.


    7. #7
      Junior Member
      Join Date
      Nov 2011
      Location
      Arizona
      Posts
      7
      had you Read my reply....you'd have seen i've already done that. i also replaced the wires, with no resolution to the issue.

    8. #8
      Senior Member
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      6,973
      Garage empty: add car
      i read your reply, you misted the wires, do you mist the coil pack?

      did you read my reply where is said the coil pack misfire will cut the rpm signal to the transmission?


    9. #9
      Junior Member
      Join Date
      Nov 2011
      Location
      Arizona
      Posts
      7
      yes misting the wires includes misting the coil pack. there was no evidence of any arcing of the coil pack...the plug wires showed some arcing. i'm going to change the plugs, and run some seafoam through it today.

    10. #10
      Senior Member
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      6,973
      Garage empty: add car
      what are you hoping the seafoam does?




    Page 1 of 4 123 ... LastLast

    Similar Threads

    1. Flashing check engine light
      By jimig1 in forum Engine & Drivetrain
      Replies: 34
      Last Post: 12-10-2012, 02:15 AM
    2. Flashing Hold Light
      By timmytaxi in forum Engine & Drivetrain
      Replies: 9
      Last Post: 09-19-2012, 09:27 PM
    3. Check engine light flashing
      By EvySpeedy254 in forum Troubleshooting and Maintenance
      Replies: 11
      Last Post: 01-06-2012, 06:07 PM
    4. flashing check engine light (after full acceleration from a stop)
      By bjorkmae in forum Troubleshooting and Maintenance
      Replies: 3
      Last Post: 07-18-2011, 07:03 PM
    5. Got a flashing "HOLD" on my dash today????
      By redrob in forum Engine & Drivetrain
      Replies: 8
      Last Post: 03-03-2011, 04:17 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •