•  
    Results 1 to 2 of 2

    Thread: 09 Aveo started then died? Help!

    1. #1
      What's wrong with my car?
      Join Date
      Mar 2018
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      09 Aveo started then died? Help!

      2 weeks ago, I started my 09 Aveo to warm up. Went out 10 minutes later and it was off. Full gas tank. Tried to restart and won't do anything! Any ideas?



    2. #2
      What's wrong with my car?
      Join Date
      Mar 2018
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Found out problem. Engine Control Module burned up. $900+ to fix, not sure if worth it!



    Similar Threads

    1. 04 Aveo died while driving
      By Brian Champagne in forum Troubleshooting and Maintenance
      Replies: 6
      Last Post: 04-29-2017, 01:20 PM
    2. Getting started in Ohio
      By Beneficiall in forum Introductions
      Replies: 0
      Last Post: 12-16-2013, 05:25 AM
    3. FINALLY! I started some work on my Aveo!
      By MoneyMike in forum Photographs and Videos
      Replies: 10
      Last Post: 01-27-2013, 07:54 PM
    4. 2007 Aveo died when pushing in clutch
      By Ttppss in forum Troubleshooting and Maintenance
      Replies: 22
      Last Post: 04-10-2012, 04:06 AM
    5. Rattling Noise-Just Started
      By Weirdo_Joe in forum Troubleshooting and Maintenance
      Replies: 19
      Last Post: 03-05-2011, 12:24 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •