•  
    Results 1 to 7 of 7

    Thread: Power door locks malfunctioning

    1. #1
      What's wrong with my car?
      Join Date
      Dec 2013
      Location
      Guam
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Power door locks malfunctioning

      Hi folks, I've got a 2007 Aveo5 hatchback, and for the last few months my power doors have been making a clicking sound every once in awhile (maybe once every few times the car is driven). They weren't locking or unlocking, just making some random noises on occassion. When my wife and I took a month long trip, we came back to find that the battery was completely dead, and wouldn't hold a charge after it was jumped. It was about time to replace the battery anyway, so no big deal.

      Well, when we replaced the battery, it turned out to be faulty and blew a bunch of fuses out, such as the windshield wiper fuse, the 100A alternator fuse, and a few others. Anyway, we got a good battery and replaced all the fuses, and for the most part the car is working normally again. However, the power door locks are now pratically going berserk, the sounds are much louder and they are more frequent. Also, they are causing a current drain on the battery; about 650mA. So I had to yank that fuse so it doesn't drain it down.

      Anyone have any ideas on how to troubleshoot this issue? I can't find a location for a power door lock relay, or any sort of wiring diagram. There may be a short somewhere. Any help would be greatly appreciated. Thanks!



    2. #2
      What's wrong with my car?
      Join Date
      Jun 2017
      Location
      Pennsylvania
      Posts
      3
      Thanks
      0
      Thanked 0 Times in 0 Posts
      I know this is an old thread, but did you ever get a solution to this issue? My son has a 2008 Aveo 5 and recently the door locks started clicking repeatedly after the alarm system is armed by the keyless entry FOB. It seems as if the RKE system is trying to re-lock all of the doors every second or so. It won't do it if the drivers door is left unlocked. Anyone else have this problem? Any suggestions for diagnosing/fixing it?

    3. #3
      What's wrong with my car?
      Join Date
      Aug 2017
      Location
      Danville CA
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Kharon--same issue here on 2008 Aveo 5. 2008 Aveo 5 hatchback. We replaced the trunk actuator but still happening. Did you or anyone find a solution?

    4. #4
      What's wrong with my car?
      Join Date
      Jun 2017
      Location
      Pennsylvania
      Posts
      3
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Quote Originally Posted by bgreeneee1 View Post
      Kharon--same issue here on 2008 Aveo 5. 2008 Aveo 5 hatchback. We replaced the trunk actuator but still happening. Did you or anyone find a solution?
      Did some quick tests. Theory - the drivers door lock mechanism feeds back to the under dash control module when the security system is armed. If the drivers door mech does not tell the ctrl mod that the door is secure, the module repeatedly tries to activate the lock solenoids on all 5 doors. I would open the drivers door inside panel and use a meter to check it before ordering parts. I'll post results when I get around to that. Until then, I pulled the fuse so the solenoids don't wear out, and I'm open to any info that will confirm or debunk my theory.

    5. #5
      What's wrong with my car?
      Join Date
      Aug 2017
      Location
      Alabama
      Posts
      2
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Having the same issue on 2009...car acts like it's possessed. Lock doors with remote and they go nuts...unlocking and locking repeatedly....when you can get it to stop it there is a remaining click.

    6. #6
      Administrator MetroMPG's Avatar
      Join Date
      Jan 2007
      Location
      1000 Islands, Ontario, Canada
      Posts
      3,987
      Thanks
      198
      Thanked 101 Times in 83 Posts
      I searched the forum for a solution to this problem... several owners have posted about it, but nobody has reported back with a solution.

    7. #7
      What's wrong with my car?
      Join Date
      Aug 2017
      Location
      Usa
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      I joined this site just for this thread. My daughter's 2007 aveo 5 is doing the same exact craziness with the power door locks as others have described in this thread. Please post if you have found any answers. Thanks!!!




      Last edited by Comporder1; 08-22-2017 at 01:20 AM.

    Similar Threads

    1. Adding power door locks
      By bjorkmae in forum Audio, Video & Interior
      Replies: 41
      Last Post: 05-20-2016, 11:19 AM
    2. kits to convert to power locks
      By roxy55 in forum Audio, Video & Interior
      Replies: 9
      Last Post: 05-07-2013, 05:29 PM
    3. Power door locks problems - requires a locksmith
      By Letitiota in forum General Discussion
      Replies: 1
      Last Post: 04-21-2013, 08:22 PM
    4. Power locks
      By gone6 in forum Audio, Video & Interior
      Replies: 2
      Last Post: 07-16-2012, 01:18 AM
    5. Aveo power locks (what i will need to do)
      By luklyz in forum Audio, Video & Interior
      Replies: 1
      Last Post: 06-14-2009, 06:10 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •