• AveoForum decals - get one free, or buy
    Results 1 to 7 of 7

    Thread: PO 2096 code

    1. #1
      Junior Member
      Join Date
      Mar 2013
      Location
      IL
      Posts
      4
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      PO 2096 code

      New to the forum. I have a 2008 Chevy Aveo LS and cannot clear a PO2096. I've changed the O2,plugs tried Fuel injector cleaner and seaform. Next step was to clean the sensor in the air box. Any help?



    2. #2
      Senior Member
      Join Date
      Aug 2012
      Location
      Northeast
      Posts
      643
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      How many miles on your Aveo, and did the old plugs look good/normal? How long since you hung on the new parts? I know of one other (different) lean code that took a bit of time to "unlearn" its way out of the computer. Different vehicle, but the concept is the same. Maybe try to disconnect the battery a couple times and give it chance to reprogram with additional starts?

    3. #3
      Junior Member
      Join Date
      Mar 2013
      Location
      IL
      Posts
      4
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Chevy Aveo 2008 PO 2096

      Quote Originally Posted by avguy View Post
      How many miles on your Aveo, and did the old plugs look good/normal? How long since you hung on the new parts? I know of one other (different) lean code that took a bit of time to "unlearn" its way out of the computer. Different vehicle, but the concept is the same. Maybe try to disconnect the battery a couple times and give it chance to reprogram with additional starts?

      Thanks I"reset it at least 5 times with the OBII reader. The plugs actually looked pretty good but had 25000 on them so went ahead and changed them. I also tried cleaning the sensor in the air intake hose off the air cleaner with alcohol. Was going to try brake cleaner next . Right now the code is out. I'll try the battery and spray if it comes back. Please any suggestions are welcome. Thanks again

    4. #4
      Junior Member
      Join Date
      Mar 2013
      Location
      IL
      Posts
      4
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Still have the code. I ordered a new intake hose with the sensor and valve. This is the hose off the air canister. I'll also try resetting with a battery disconnect. Any other suggestions ? Thanks

    5. #5
      Junior Member
      Join Date
      Mar 2013
      Location
      North Carolina
      Posts
      1
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Do you hear an exhaust leak?

    6. #6
      Junior Member
      Join Date
      Mar 2013
      Location
      IL
      Posts
      4
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Quote Originally Posted by Bananaman View Post
      Do you hear an exhaust leak?
      I did . The resonator was broke off/weld was off the flange. I replaced it with a straight pipe. I have not have the code come back yet. So after replacing the O2, pipe, intakr hose, plugs and resetting with the battery disconnect I think I may have licked it. I was using the OBII reader for resets so at this point I think doing a reset with the battery may have done it or the Intake Hose. Thanks alot for your help

    7. #7
      Member
      Join Date
      Jan 2012
      Location
      DC
      Posts
      40
      Garage empty: add car
      Thanks
      0
      Thanked 0 Times in 0 Posts
      is the resonator the flex pipe? I had a repair performed by Midas to the flex pipe and since then I had the P2096 code coming up.

      see my topic for history.
      Code appearing and disapearing ? possible?



    Similar Threads

    1. Code P0118
      By boyan1st in forum Troubleshooting and Maintenance
      Replies: 3
      Last Post: 01-27-2013, 09:56 AM
    2. p0420 code
      By ajk148700 in forum Troubleshooting and Maintenance
      Replies: 2
      Last Post: 12-14-2012, 11:29 PM
    3. P00B7 code..what is it?? Help please
      By redaveoowner in forum General Discussion
      Replies: 2
      Last Post: 10-10-2012, 02:20 AM
    4. Code p2096
      By Jwurth in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 08-31-2012, 01:55 PM
    5. OBD Code Questions
      By SpiffWilkie in forum Troubleshooting and Maintenance
      Replies: 0
      Last Post: 07-13-2012, 12:45 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •