• AveoForum decals - get one free, or buy
    Results 1 to 7 of 7

    Thread: 2008 Aveo - Brake and battery indicator lights on dimly.

    1. #1
      Junior Member
      Join Date
      Jun 2011
      Location
      wi
      Posts
      3
      Garage empty: add car

      2008 Aveo - Brake and battery indicator lights on dimly.

      Hi - new to forum.

      I have a 2008 Aveo with 105k on it. Very few problems so far, knock on wood. Last month I had a headlight go out so I replaced both as the other one usually goes out shortly thereafter. Last week the wife tells me that both the low beam head lights are out. I thought this was strange but I had kept the one old headlight as a spare and found out that I indeed blew both low beams out. I decided to take a short drive and in a mile or so I noted that the battery light was on. I turned around and went home. In the driveway the battery was dead as a doornail...classic symptoms of a bad alternator.

      I replaced the alternator with one from NAPA, I noticed that the battery light was still on as well as the brake light, didn't notice the brake light when this all started, I may have missed it though. - did the dummy check with a meter on the battery, 13.2 volts when off, 13.5 at idle, 14.2 when held at about 2k rpms. Swapped the battery, drove about 70 miles with the AC and Brights on - battery is still charged fine. Brakes work fine.

      Anyone have any thoughts on why I would have the alternator and brake lights on dimly when running? Secondly, I did notice that when I put on the parking brake BOTH the battery and the brake indicator lights go bright, not just the brake indicator.

      Thans for any help offered,
      Seahag



    2. #2
      Senior Member
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      7,263
      Garage empty: add car
      so there are no more actual running issues? do the headlights work again?

      this sounds like a bad ground?


    3. #3
      Junior Member
      Join Date
      Jun 2011
      Location
      wi
      Posts
      3
      Garage empty: add car
      Yep, swapped out the second headlight and all are working. Engine, brakes charging are all fine.

    4. #4
      Senior Member
      Join Date
      Sep 2008
      Location
      Pittsburgh
      Posts
      7,263
      Garage empty: add car
      so all the issue "might" be in the gauge cluster. or the common part of that harness.

      Is anything else on at the time?


    5. #5
      Junior Member
      Join Date
      Jun 2011
      Location
      wi
      Posts
      3
      Garage empty: add car
      Thanks for your reply,

      I checked out the grounds to the battery and the alternator is bolted down tight. I've tried running with various things in and off and on states with no real change except that both indicator lights get brighter when I pull the parking brake (both "brake" and "battery" lights) The thing that gets me is none of this was going on before the alternator failure.

      I think I'm going to try and locate the wiring for that emergency brake switch and trace that back to its source - maybe I fried something there...thoughts?

    6. #6
      Junior Member
      Join Date
      Aug 2012
      Location
      Illinois
      Posts
      1
      Garage empty: add car
      I am having the same issue. I just recently replaced the oil and brake pads and after doing this the battery light and brake light came on and will not go off? My checking of the alternator is showing 12.5 volts. Never a dead battery though. Help me figure this out.

    7. #7
      Junior Member
      Join Date
      May 2013
      Location
      trinidad
      Posts
      8
      Garage empty: add car
      i am also having the same issue. my 2006 aveo just had the alternator replaced after 300k. the battery light is dimly lit in the daytime. an auto electitian pal told me the problem most likely was a blown diode in the instrument cluster. i checked them all by no problems found. i think im gonna change the ic on the display board just to see if it makes a difference. please note if your engine sounds like a diesel engine one day the bearing on your alternator may be bad



    Similar Threads

    1. No brake lights! Problem solved!
      By johnygogo in forum Troubleshooting and Maintenance
      Replies: 17
      Last Post: 10-15-2013, 12:29 AM
    2. Right brake light & both reverse lights not working!
      By AMMsterz in forum Troubleshooting and Maintenance
      Replies: 5
      Last Post: 09-03-2011, 01:32 PM
    3. Day time running lights or headlight circuit draining battery
      By mcyclonegt in forum Troubleshooting and Maintenance
      Replies: 4
      Last Post: 07-18-2010, 03:02 AM
    4. 2008 Aveo RS Carbon Creations Splitters and Smoked Lights
      By ChevyAveoRS in forum Photographs and Videos
      Replies: 7
      Last Post: 01-09-2009, 04:06 AM
    5. tire pressure indicator
      By lowaveo17 in forum Troubleshooting and Maintenance
      Replies: 6
      Last Post: 09-28-2008, 01:29 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •