•  
    Results 1 to 4 of 4

    Thread: Long time lurker, finally first post. Yellow 2004 Aveo Hatchback

    1. #1
      What's wrong with my car?
      Join Date
      Mar 2017
      Location
      Modesto
      Posts
      7
      Thanks
      1
      Thanked 0 Times in 0 Posts

      Long time lurker, finally first post. Yellow 2004 Aveo Hatchback

      Hello all, my name is John, friends call me Johnny. I have been lurking your forums for a very long time and today I finally made an account and plan on posting more. You see I need some help as my 2004 Aveo is not doing well as of this week. But I will post more about that is the appropriate section later. As stated I have a 2004 Chevy Aveo that I bought new Labor Day weekend way back in 2004. She is a bright yellow hatchback with 168,000+/- miles. She has only once (before now) let me down when the plastic thermostat housing broke back in I think 08' or 09'. Even though I take a lot of grief for owning her I can say I have been proud to own her all these years and I was hoping one day to maybe hand her down to my son when he is old enough to drive. Shes not pretty, but shes mine lol.





    2. #2
      Administrator Daox's Avatar
      Join Date
      Jan 2007
      Location
      Wisconsin
      Posts
      2,349
      Thanks
      124
      Thanked 63 Times in 53 Posts
      Welcome to posting Johnny! Glad to have another lurker post.

    3. #3
      Almost time to do my timing belt xintersecty's Avatar
      Join Date
      Sep 2010
      Location
      West Union, SC
      Posts
      1,599
      Thanks
      75
      Thanked 156 Times in 139 Posts
      It's great you came of the closet and quit peeking through the keyhole Nice car!
      Please do not power off, firmware update pending.....

    4. #4
      What's wrong with my car?
      Join Date
      Mar 2017
      Location
      Modesto
      Posts
      7
      Thanks
      1
      Thanked 0 Times in 0 Posts
      Thank you both! I have learned a lot over the last few weeks with all the great info here. Seams like the 'heyday' of this forum may have come and gone. Still active here, but it looks like I missed the boat of 2010 and 11'. Either way I will try and stay active here. I might be needing some more repairs soon.





    Similar Threads

    1. Replies: 5
      Last Post: 10-13-2015, 07:48 PM
    2. Yellow bird. :: 2004 Chevrolet Aveo LS Hatchback (Garage entry)
      By MetroMPG in forum Members' Aveos / Garages
      Replies: 0
      Last Post: 12-18-2014, 04:47 PM
    3. Idles fine, but stalls/dies at 2000+ rpm - long post, please help
      By ATWork8803 in forum Troubleshooting and Maintenance
      Replies: 19
      Last Post: 02-20-2014, 01:47 PM
    4. Long Time No Post...
      By gonzokidd in forum General Discussion
      Replies: 6
      Last Post: 09-21-2008, 11:39 PM
    5. Well I did it. Got the 2008 Aveo Hatchback LT. Yellow
      By djl_ottawa in forum General Discussion
      Replies: 4
      Last Post: 07-03-2008, 02:44 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •